Was this page helpful?
Yes No

Extract API 2.0

The Extract API 2.0 contains a set of functions for creating extracts. Using the Extract API you can:

  • Create and populate extract (.hyper) files to improve performance and provide offline access to your data sources.

  • Write a program that connects to data sources that are not currently supported by Tableau, and then write the data into a .hyper file for use later by Tableau.

  • Write a program to create an extract that contains multiple tables. For information about creating extracts with multiple tables, see What's New in the Extract API 2.0. For more information, see the blog post, You can now choose multiple table storage for extracts.

Note: Use the Extract API 2.0 to create .hyper extract files for Tableau 10.5 and later. Use the Tableau SDK to create .tde extract files for previous versions of Tableau. For more information about the change in extract file formats, see Extract Upgrade to .hyper Format

For information about how to programmatically publish the extracts to Tableau Server, see the Tableau Server REST API and the Tableau Server Client (Python) library.

Tableau Server requirements

To publish an extract created using this Extract API, the server you are publishing to must be running Tableau Server 10.5 or later.

Supported platforms and languages

The Extract API works on Windows Server 2008 R2 or later, or Windows 7 or later, Mac OS X (10.9 and later), and Linux systems. The Extract API has been verified to work on the following Linux distributions:

  • Fedora 18 and later

  • CentOS 7 and later

  • Ubuntu 12.04 and later

Though the Extract API is assumed to work on other distributions as well, this has not been verified through testing.

The Extract API supports the following languages:

  • C

  • C++

  • Java

  • Python 2.x and Python 3.x.